CS9320 flashing LED

Navigation box for OEM car monitors and aftermarket multimedia receivers. Operates on Android 4.1.1 platform. Uses GPS and GLONASS systems.

Moderator: Germes

CS9320 flashing LED

Postby Sueco » 06 Dec 2017, 13:18

Hi,

I have a CS9320 which worked just fine for 6 months, then yesterday I got no signal on the screen. After checking, the unit, the status LED instead of going solid green flashes between orange and green with a period of around 1 second. Has anybody experienced something like this?

Thank you!
Sueco
 
Posts: 4
Joined: 06 Dec 2017, 13:15
Location: Sueca
Car: MB A-class

Re: CS9320 flashing LED

Postby Yuretz » 06 Dec 2017, 14:16

Hello.
"flashes between orange and green with a period of around 1 second" is normal. It means that the GPS satellites are found. Solid green means that the GPS unit is out of order . Solid red means that the GPS satellites are not found.

Check the RGB cable. Try connecting it via RCA for testing. Try updating the firmware:
Here's the latest OS update Android 4.3 https://www.odrive.com/s/92a834ac-f7b0- ... 2-58d264e9 .

Here's the FW update https://www.odrive.com/s/7074f343-d3c7- ... 2-58d26500 . Should be updated after you have update your system to Android 4.3 to avoid box reboots.

How to update OS : manual https://car-solutions.com/nfs/product/8 ... _guide.pdf , last page .

How to update FW: copy *.bin file to the SD card or USB drive. Go to the Settings-Customization-Advanced settings-7777(code)-FW upgrade, select your *.bin file .

After update disable "car mode" in the car mode settings and default settings https://car-solutions.com/nfs/product/8 ... _guide.pdf , page 17-18 .
User avatar
Yuretz
CarSolutions Team
 
Posts: 226
Joined: 07 Feb 2012, 16:53
Location: Ukraine
Location: Lviv/Ukraine
Car: Fast as the wind

Re: CS9320 flashing LED

Postby Sueco » 06 Dec 2017, 19:03

Hi,

The composite video output signal appears to work, however I've checked the RGB wiring and appears to be properly connected, so at this point I don't know if the failure lays in the RGB source or the receiver, anyway I made the stupid mistake of messing with the video output format while trying to figure out what's happening, so now I'm trying to reset the unit's parameters using the wp9920_update.zip file, without luck until now, I'm going to try until I get back the video output in interlaced composite and then recheck the RGB signals with a 4 channels scope.

Thanks and BR
Sueco
 
Posts: 4
Joined: 06 Dec 2017, 13:15
Location: Sueca
Car: MB A-class

Re: CS9320 flashing LED

Postby Yuretz » 07 Dec 2017, 09:49

Try setting 480x234 resolution in the Screen change settings via CVBS. After reboot it should work via RGB.
User avatar
Yuretz
CarSolutions Team
 
Posts: 226
Joined: 07 Feb 2012, 16:53
Location: Ukraine
Location: Lviv/Ukraine
Car: Fast as the wind

Re: CS9320 flashing LED

Postby Sueco » 07 Dec 2017, 17:17

Thanks all, it's been solved, apparently the syn signal wasn't contacting properly in the mini DIN connector that comes with the CS9320 cable.
Sueco
 
Posts: 4
Joined: 06 Dec 2017, 13:15
Location: Sueca
Car: MB A-class


Return to CS9320 Navigation Box on Android

Who is online

Users browsing this forum: No registered users and 1 guest